Skip to content

Leverage Releases & Versioning

Binbash Leverage™ and its components intends to be backward compatible, but due to the complex ecosystems of tools we manage this is not always possible.

It is always recommended using the latest version of the Leverage cli with the latest versions of the Reference Architecture for AWS. In case that's not possible we always recommend pinning versions to favor stability and doing controlled updates component by component based on the below presented compatibility matrix table.

Compatibility Matrix

Leverage Ref Arch 🏗 ☁ version Leverage Cli Terraform Terraform AWS provider K8s EKS
v1.8.1 v1.7.2 >= 1.1.9 3.27.x, 4.x.y 1.20-1.22
v1.7.2 v1.6.2 >= 1.1.3 3.27.x, 4.x.y 1.17-1.19
v1.3.73 v1.2.0 1.0.x 3.27.x 1.17
v1.3.25 v1.0.10 0.14.x 3.27.x 1.17

Releases which are crossed out should work, but are unlikely to get security or other fixes. We suggest they should be upgraded soon.

Release Schedule

This project does not follow the Terraform or other release schedule. Leverage aims to provide a reliable deployment and operations experience for the Binbash Leverage™ Reference Architecture for AWS, and typically releases about a quarter after the corresponding Terraform release. This time allows for the Terraform project to resolve any issues introduced by the new version and ensures that we can support the latest features.

Read more